lejosfirmdl "Nxt not found" (windows)

This is where you talk about the NXJ software itself, installation issues, and programming talk.

Moderators: roger, imaqine, 99jonathan

User avatar
pEhrlich
Advanced Member
Posts: 158
Joined: Fri Jan 04, 2008 1:38 am
Contact:

lejosfirmdl "Nxt not found" (windows)

Postby pEhrlich » Sun Jan 06, 2008 10:28 pm

Hi

I'm trying to put the lejos firmware onto a nxt, but am getting nowhere. I have the nxt reset, it shows up in the device manager correctly (Firmware Update Mode), and I believe all the software is installed correctly: JRE 6 update 3, the lego usb driver, and libusb.

I have tried with two different bricks on the same computer, both get the same error. Is there a way to do this on mac yet?

Here is the error:
lejosfirmdl
NXJ_HOME is C:\java\lejos_nxj
Setting fmcn to 50
Checking VM C:\java\lejos_nxj/bin/lejos_nxt_rom.bin ... VM OK.
Checking Menu C:\java\lejos_nxj/bin/StartUpText.bin ... Menu OK.
NXT not found. Is it properly plugged in via USB?


Thanks!

99jonathan
Moderator
Posts: 122
Joined: Thu Mar 01, 2007 5:30 am

Postby 99jonathan » Mon Jan 07, 2008 5:06 am

First, see if your normal legos mindstorms software can find the brick. If it can, then your problem is with libusb. I had to install it twice to get it to work. Otherwise, your problem will be a lot harder to nail down. Remember to install libusb in a directory with no spaces!

jvance
New User
Posts: 22
Joined: Sun Aug 12, 2007 2:22 am

Postby jvance » Mon Jan 07, 2008 9:02 pm

Libusb is a pain in the neck(it did something to my computer),but my pc still runs ok. I would install it again, but you don't call lejofirmdl, you call nxjflash. Maybe this will work...

User avatar
kirkpthompson
leJOS Team Member
Posts: 305
Joined: Wed Dec 05, 2007 1:27 am
Location: New Mexico, USA

Postby kirkpthompson » Tue Jan 08, 2008 1:08 am

Make sure Libusb is installed in a directory with NO spaces in the path.

User avatar
pEhrlich
Advanced Member
Posts: 158
Joined: Fri Jan 04, 2008 1:38 am
Contact:

Postby pEhrlich » Tue Jan 08, 2008 7:34 pm

kirkpthompson wrote:Make sure Libusb is installed in a directory with NO spaces in the path.


bingo! success!

clhunter
New User
Posts: 3
Joined: Mon Jan 28, 2008 2:12 am
Location: IOWA

LibUSB 1.12.xxx

Postby clhunter » Mon Jan 28, 2008 7:01 pm

I have found on both XP and Vista machines that 1.12 version of LibUSB will not detect the brick. I had to use a previous version of LibUSB like 1.10. Once I uninstalled 1.12 and installed a previous version it detected the brick without a problem.

Hope this helps. Also if you have Vista make sure you install with windows compatibility mode enabled on the install exe. Otherwise you will be learning the beauty of restore points.
Where there is code there is code


Return to “NXJ Software”

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest