iCommand Bluetooth problem, need urgent help!

This is where you talk about the NXJ software itself, installation issues, and programming talk.

Moderators: roger, imaqine, 99jonathan

panzermarko
New User
Posts: 5
Joined: Wed Feb 14, 2007 10:02 am

iCommand Bluetooth problem, need urgent help!

Postby panzermarko » Fri Mar 09, 2007 4:44 pm

Hi!

I'm a programmer student from Hungary. My thesis is about Lego NXT. My hardware independent code is ready, but i still have a lot of problem with controlling the machine via BT. I totally reinstalled the applications, updated drivers and firmware. But sometimes even the official IDE failes to download the programs via BT. And it's very strange, that i have 2 ports defined for NXT ( 3 input port (?),8 output port (?) ): (Sorry for localized Windows)

Image

Two tipical errors when running programs:

1,

Looking for 'icommand.properties' in working dir: H:\Documents and Settings\Panzermarko\workspace\Nxt_test
NXTCOMM = COM8
Stable Library
=========================================
Native lib Version = RXTX-2.1-7
Java lib Version = RXTX-2.1-7
Exception in thread "main" java.lang.UnsatisfiedLinkError: native_psmisc_report_owner
at gnu.io.CommPortIdentifier.native_psmisc_report_owner(Native Method)
at gnu.io.CommPortIdentifier.open(CommPortIdentifier.java:354)
at icommand.nxtcomm.NXTComm.open(Unknown Source)
at icommand.nxtcomm.NXTCommand.<clinit>(Unknown Source)
at icommand.platform.nxt.Sensor.setTypeAndMode(Unknown Source)
at icommand.platform.nxt.I2CSensor.<init>(Unknown Source)
at icommand.platform.nxt.Ultrasonic.<init>(Unknown Source)
at getTacho.main(getTacho.java:13)

2,

Looking for 'icommand.properties' in working dir: H:\Documents and Settings\Panzermarko\workspace\Nxt_test
NXTCOMM = COM3
Stable Library
=========================================
Native lib Version = RXTX-2.1-7
Java lib Version = RXTX-2.1-7
Error while connecting NXTCommand() constructor
gnu.io.NoSuchPortException
at gnu.io.CommPortIdentifier.getPortIdentifier(CommPortIdentifier.java:218)
at icommand.nxtcomm.NXTComm.open(Unknown Source)
at icommand.nxtcomm.NXTCommand.<clinit>(Unknown Source)
at icommand.platform.nxt.Sensor.setTypeAndMode(Unknown Source)
at icommand.platform.nxt.I2CSensor.<init>(Unknown Source)
at icommand.platform.nxt.Ultrasonic.<init>(Unknown Source)
at getTacho.main(getTacho.java:13)
Exception in thread "main" java.lang.NullPointerException
at icommand.nxtcomm.NXTComm.sendData(Unknown Source)
at icommand.nxtcomm.NXTCommand.sendRequest(Unknown Source)
at icommand.nxtcomm.NXTCommand.setInputMode(Unknown Source)
at icommand.platform.nxt.Sensor.setTypeAndMode(Unknown Source)
at icommand.platform.nxt.I2CSensor.<init>(Unknown Source)
at icommand.platform.nxt.Ultrasonic.<init>(Unknown Source)
at getTacho.main(getTacho.java:13)


I always try restarting the NXT, sometimes the pc. Sometimes it works, sometimes not. :-(
What's more, the NXT always wants a code even when i disable it in the windows. More frustrating when windows forgets my NXT, and i need to make the connection again. Which in the most cases won't work.
To tell the truth, i can't use it for real programming work. I have 1 month to finish my thesis. Please help me, if u can.
(I have Windows XP sp2, latest driver, 1.4 firmware. For Java latest RXTX, Eclipse)

User avatar
bbagnall
Site Admin
Posts: 392
Joined: Fri Aug 04, 2006 4:03 pm

Postby bbagnall » Fri Mar 16, 2007 7:26 pm

Have you tried looking through the troubleshooting section of the readme file that comes with iCommand? It addresses the problems you are having.


Return to “NXJ Software”

Who is online

Users browsing this forum: Bing [Bot], Yahoo [Bot] and 1 guest