Class not found [SOLVED]

This is where you talk about the NXJ software itself, installation issues, and programming talk.

Moderators: roger, imaqine, 99jonathan

New User
Posts: 2
Joined: Tue May 15, 2007 2:09 pm

Class not found [SOLVED]

Postby jendrik » Sat Oct 13, 2007 2:46 pm

Hello everyone,

I have a small Problem here you guys might be able to help me with.
So far I have built a robot which is able to drive around and follow lines perfectly, but as soon as I try to add Bluetooth Communication I get the following error message when I try to link the class file:

Class (file java/io/FilterInputStream.class) not found in CLASSPATH .:/Users/jendrik/Documents/Workspace/lejos_nxj/3rdparty/lib/bcel-5.1.jar:/Users/jendrik/Documents/Workspace/lejos_nxj/3rdparty/lib/commons-cli-1.0.jar:/Users/jendrik/Documents/Workspace/lejos_nxj/lib/jtools.jar:/Users/jendrik/Documents/Workspace/lejos_nxj/lib/classes.jar

More precisely this happens as soon as I import and

Thanks for your help,

Last edited by jendrik on Sun Oct 14, 2007 2:43 pm, edited 1 time in total.

leJOS Team Member
Posts: 965
Joined: Mon Feb 05, 2007 1:27 pm

Postby lawrie » Sat Oct 13, 2007 9:05 pm

It looks like you have compiled with the standard Java libraries and not classes.jar. If you are using Eclipse, it can do an automatic compile that causes this. Make sure you compile with nxjc immediately before linking, or use an ant build file. Adding classes.jar to the Eclipse project might also help.

New User
Posts: 2
Joined: Tue May 15, 2007 2:09 pm

Postby jendrik » Sun Oct 14, 2007 2:44 pm

Thanks. That was it. I just removed the standard Java libraries in Eclipse and it worked right away.

Return to “NXJ Software”

Who is online

Users browsing this forum: Bing [Bot] and 3 guests